Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Corsa TPS issues - Help or forum suggestions?
25-11-2019, 09:13 AM,
#1
Corsa TPS issues - Help or forum suggestions?
Hi Everyone

I know this is a BMW forum, but really need help with my Corsa Lite. I don't seem to find any active Opel forums that are SA based...

I have this nagging issue of my Corsa Lite 1.4 sputtering and misfiring all over the place on constant throttle and slight deceleration. Acceleration is smooth but down on power.

I have replaced the following:

Coil pack
HT Leads
Spark plugs
TPS sensor
IAC valve
MAP sensor
Crank Position Sensor
Fuel relay
Fuel Pump
Fuel pressure regulator
Earth strap
Crank timing sprocket
Cam belt and tensioner

All this was done after consulting multiple Opel "experts", and still didn't solve my problem. This weekend I had this crazy idea to just unplug the TPS sensor and voila, the car ran like a new car, only the CEL stays lit, obviously due to TPS error. Plug it back in, problem returns. This is a brand new TPS. Does anyone know about this problem? There is a lot of reference to this on the net but no solid diagnosis or solution. I have attempted with several readers to get codes and failed. Don't have the cash to go to stealers for R1000 per hour labour to diagnose. Any advice will be great.

Thanks guys

Current: E46 320D F/L (His)
Colt Rodeo 2.8 tdi 4x4 (Her donkey)

Ex: E53 X5 3.0d A/T M-Sport
Ex: BMW 330d E46 F/L
Ex: E87 118i (Hers)
Like Post Quote this message in a reply
25-11-2019, 09:21 AM,
#2
RE: Corsa TPS issues - Help or forum suggestions?
If everything worked after unplugging the TPS, I would say you have a faulty new TPS. I've purchased a few items for Opels from Goldwagen and have found some to be faulty. Often with the wrong angle connections or faulty out the box.
Like Post Quote this message in a reply
The following 1 user Likes Redshert's post:
rudolphc83
25-11-2019, 09:25 AM,
#3
RE: Corsa TPS issues - Help or forum suggestions?
This thought also occurred to me. Any way of testing the TPS before getting another one or returning to GW?

Current: E46 320D F/L (His)
Colt Rodeo 2.8 tdi 4x4 (Her donkey)

Ex: E53 X5 3.0d A/T M-Sport
Ex: BMW 330d E46 F/L
Ex: E87 118i (Hers)
Like Post Quote this message in a reply
25-11-2019, 09:57 AM,
#4
RE: Corsa TPS issues - Help or forum suggestions?
Just return it.

Current:
M135i F20 Estoril Blue 6MT - Weekend Warrior
Opel Corsa Utility 1.4 Sport - Daily

SO:
320d F30 MSport Alpine White 8sp A/T
Gone but not forgotten:
Peugeot 207 HDi 1.6 HDi
Honda Civic Type R FN2 NHB


My Build Thread: M135i
Like Post Quote this message in a reply
25-11-2019, 10:46 AM,
#5
RE: Corsa TPS issues - Help or forum suggestions?
@Gavsadler

Like Post Quote this message in a reply
25-11-2019, 10:52 AM,
#6
RE: Corsa TPS issues - Help or forum suggestions?
Hi,

We had a similar issue last year when rebuilding a Corsa C 1.8 GSi. Endless issues troubles hooting some pinging (that turned out to be the incorrect crank pulley was fitted to the car in it's past life).

But after resolving that, the car had an issue where it was hunting at idle, we also replaced all the sensors but the problem persisted. (New sensors were bought at Goldwagen).

Eventually, we reinstalled the old GM TPS, and the car idled perfectly, so Yes, I would concur with the others above that perhaps the new TPS you bought is dodgy.

Where are you based? Perhaps we can arrange a meetup to test.

2011 E90 M3 M-DCT Build thread here
2011 F25 X3 35i M-Sport Build thread here
2007 E87 130i M-Sport: Alpine Upgrade, BMWP Intake, BMWP Exhaust Build thread here
2007 Corsa C Ute 2l 16v Tebbo Bluebiggrin : Build thread Here
Like Post Quote this message in a reply
The following 1 user Likes gavsadler's post:
rudolphc83
25-11-2019, 11:50 AM,
#7
RE: Corsa TPS issues - Help or forum suggestions?
By day I am in Kempton Park. I live in Pretoria in Waverley area. I will dig around a bit, I should still have the GM TPS lying around somewhere.

Current: E46 320D F/L (His)
Colt Rodeo 2.8 tdi 4x4 (Her donkey)

Ex: E53 X5 3.0d A/T M-Sport
Ex: BMW 330d E46 F/L
Ex: E87 118i (Hers)
Like Post Quote this message in a reply
25-11-2019, 12:03 PM,
#8
RE: Corsa TPS issues - Help or forum suggestions?
Sounds eerily familiar to what my corsa did.. This is ages ago though, it would backfire and randomly just loose power as well. I remember unplugging a sensor which I believe was the TPS and the car ran.. Never sorted it out though.. Hope a replacement sensor will sort it for you Thumbs

Current:
'14 F30 335i MSport Alpine White III, Coral Red, Sat Nav, iDrive touch, PDC + reverse cam, Harman Kardon, N55 230wkw | 477wnm Rogue Performance Downpipe
'16 F30 318i LCI Manual, Alpine White III, Black Leather
[Image: banner%20final_1261154562_8282635603.png]
[Image: m_fanatic2_8387882621.jpg]
Mods: Optic Blue Lamin-X fogs, VPS light shields, CF Splitters, Mirrors, Ducktail spoiler, Aluminium interior trim upgrades...

Retired BMWs:
'12 F30 320d
'12 F20 118i
'09 E90 LCI 320i M-Sport
'07 E90 320i Excl
'91 E30 325iS Evo I
Like Post Quote this message in a reply
25-11-2019, 11:22 PM,
#9
Corsa TPS issues - Help or forum suggestions?
@dannyboyopc is your go to guy


Sent from my iPhone using Tapatalk

Melbourne Red X3 ///M Sport

[Image: sig%20pic_623252484.jpg]
Like Post Quote this message in a reply
26-11-2019, 06:27 AM,
#10
RE: Corsa TPS issues - Help or forum suggestions?
What is the part number of the OEM TPS? Need to check, but may still have one lying around that I bought for my astra but never used.

2010 X3 2.0d M-SPORT
2011 320d Exclusive




Like Post Quote this message in a reply
26-11-2019, 07:33 AM,
#11
RE: Corsa TPS issues - Help or forum suggestions?
Not sure yet, I seem to have misplaced the old TPS Fencelook

From what I understand the TPS for Corsa B and Astra F is one and the same thing?

Current: E46 320D F/L (His)
Colt Rodeo 2.8 tdi 4x4 (Her donkey)

Ex: E53 X5 3.0d A/T M-Sport
Ex: BMW 330d E46 F/L
Ex: E87 118i (Hers)
Like Post Quote this message in a reply
26-11-2019, 07:36 AM,
#12
RE: Corsa TPS issues - Help or forum suggestions?
Mine was off an Astra H. Will check and let you know.

2010 X3 2.0d M-SPORT
2011 320d Exclusive




Like Post Quote this message in a reply
26-11-2019, 07:37 AM,
#13
RE: Corsa TPS issues - Help or forum suggestions?
Bit of an update, played around a bit last night. Seems that my IAC seems to be messing around. Every time I start the car the idling is different. Could this be due to the TPS being unplugged or could this be the reason for the TPS messing around?

My logic tells me sticking IAC, stuck at a different position every time I start the car, but would not explain the misfiring when the TPS is plugged in... I think?

Current: E46 320D F/L (His)
Colt Rodeo 2.8 tdi 4x4 (Her donkey)

Ex: E53 X5 3.0d A/T M-Sport
Ex: BMW 330d E46 F/L
Ex: E87 118i (Hers)
Like Post Quote this message in a reply
26-11-2019, 10:00 AM,
#14
RE: Corsa TPS issues - Help or forum suggestions?
My Corsa has a similar issue now and again. I usually just remove the Idle Control Valve and clean it with carb cleaner and fit it again. I do it every 2nd month or so,but it is such an easy job ,that I would rather just do it than buy a new GM one,I don't really trust the GW ICVs.

Current:
e90 330d M-sport Auto -RK Motion
Opel Corsa Utility 1.4
Suzuki Tl1000

[Image: img_1954_7594118472.jpg]

Ex:
E46 320d Auto
E46 320d Manual
Kawasaki ZXR400
Like Post Quote this message in a reply
26-11-2019, 10:07 AM,
#15
Corsa TPS issues - Help or forum suggestions?
As mentioned by others, the idle control valve is problematic on the corsas.
You can either but a new one or remove it and clean it out.

As for the problems being experienced with the TPS, I would suggest that you get a new TPS sensor or a used GM sensor to test and confirm.
We have had problems before with the goldwagen sensors that fail in a short time( TPS, map sensor, etc)
Like Post Quote this message in a reply
26-11-2019, 02:15 PM,
#16
RE: Corsa TPS issues - Help or forum suggestions?
(26-11-2019, 10:07 AM)Danny@DSCmotorsport Wrote: As mentioned by others, the idle control valve is problematic on the corsas.
You can either but a new one or remove it and clean it out.

As for the problems being experienced with the TPS, I would suggest that you get a new TPS sensor or a used GM sensor to test and confirm.
We have had problems before with the goldwagen sensors that fail in a short time( TPS, map sensor, etc)


this is the main reason I have stayed away from Opel, the issues with sensors and coil packs is endless!!

Current:
2015 Silver Ford Ranger Supercab
2017 White BMW 220d F22
1992 Estoril Blue Opel SuperBoss Turbo(290wkw @ 1bar, 12,52 at Tarlton)

EX: 2009 Silver Opel Corsa Sport UTE 1.4
EX: 2011 Sapphire Black BMW 120D Coupe
[Image: 13112007008_7597948047.jpg]
Like Post Quote this message in a reply
26-11-2019, 02:36 PM,
#17
RE: Corsa TPS issues - Help or forum suggestions?
we bought an opel corsa ..brand new..ended up basically giving it away...endless issues

CURRENT: BMW E36 M3 Coupe PROJECT...plan.. 18" EwingEquips & TURBO
CURRENT: BMW 330i individual..Arizona Sun on 19's
CURRENT: DATSUN PB210 aka BIN aka "Z" Coupe 2L on EwingEmotions
CURRENT: AUDI A5 on 20" Concavos
CURRENT: Rothmans VFR400 NC30 PROJECT
CURRENT: Repsol VFR400 NC30 PROJECT
EX: BMW 330i, BMW 330i, Range Rover 4.6 HSE Vogue, FORD XR6 & RS Turbo, OPEL Monza 200iCD16V, Toyota GLi Exec, VTEC, ALFA Giulietta & GT Junior stepnose, a few mingers
Like Post Quote this message in a reply




Users browsing this thread:
1 Guest(s)

Return to Top