Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Faulty EWS on Z3
06-11-2019, 03:06 PM
Post: #1
Faulty EWS on Z3
Hi there Nathan, i had a very peculiar fault on my E36, Z3, 2.8L....when i turn the key the engine turned over but did not start...when it did start eventually it was missing quite a lot when it idles, but when i drive it there was absolutely no problem!! I had it to 7 different guys who all had their computers on it but could not find the fault. I myself is an electronical technician and tried my hand in diagnosing the fault which i am good at. I found that the immobilizer was bridged out and thus the EWS was thus not in play per say....with the 7'th auto-electrician who wanted to also give up, I made mention of something i came across with the EWS module. After i tested most of the static components like the resistors and capacitors, I found that some of the E-square Prom was not making contact with the PC-board tracts. I re-soldered the pins and found it to be good. but still the car started badly. So I thought that it cant be the board and left it. But did find that when i have the board plugged into the system and i hold it with my left hand and softly touched the track side of the pc-board the car seemed to start quicker then normal but thought i might make a mistake in my assumption. I mentioned this experience to the auto-electrician who's eyes lid up when i told him this...later the day he phoned me back and told me the car was fixed!! What he did was he programmed that EWS board out of the system and it starts up every time without any problem. I have the EWS board in my garage sitting on a shelf. No wonder the Immobilizer was bridged out as the person before me could not find the fault on the EWS board and just bridged it out. Looks like later on the fault on the board caused the system to malfunctioned to the point that the car started badly....what was also funny was that every time i tried to start the car with the fault still on....it took about 17 seconds before it gave the idea it wants to start...every time....but obviously after the board was programmed out of the ECU system...it starts right up now....thought i tell this as it might be that you or someone else might run into the same problem.
Find all posts by this user
Like Post Quote this message in a reply
Post Reply 




User(s) browsing this thread:
1 Guest(s)

Return to TopReturn to Content