Post Reply 
 
Thread Rating:
  • 1 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
N55 JB4 clicking
08-06-2017, 10:06 AM
Post: #1
N55 JB4 clicking
Hi fellow fanatics,

My JB4 causes some clicking in the throttle body during idle. After complaining about this to the manufacturers I eventually ended up buying a new board. Connected this last night, an the problem remains.SmashScreen If the JB4 is removed - no clicking what so ever.

The car throws no codes and auto delete is off.

I took the car for a drive with the new board and I was getting boost up to 15psi on map 4RedNo On map one probably 17psi.

I stopped driving her hard as I don't want to damage anything.
Next thing the water pump switches on while the car is off. This ran for a good couple of minutes until I inserted they key. I don't have OCC, so should not be getting the common water pump fault others experience. so now I'm absolutely confused.....and hating JB4.

I know that only logs will sort out the boost issue, but has anybody experience with-
1. the throttle clicking/ ticking &
2. the water pump switching on.

FYI. My car has new coils, injectors, water pump, HPFP and spark plugs so very much doubt its a fueling or timing issue.

Please helpBlueCry

'12 335i MSport "The Hulk"
'05 XRSi "The Black Pearl"
'97 323i "Silas"
'99 RXi

Previous:
'03 XRSi "Kit"
'95 180i SPORT "The AFE Authority"
'94 160i RS
'99 Polo playa
Find all posts by this user
Like Post Quote this message in a reply
08-06-2017, 10:40 AM
Post: #2
RE: N55 JB4 clicking
Did you by any chance do any firmware updates on the JB

AKASH
Masstronix E90 335i AT Sportpack (JB4, DP, DCI. Race flash 265wkw @622NM at KAR)
E90 323i Sportpack
Find all posts by this user
Like Post Quote this message in a reply
08-06-2017, 11:51 AM
Post: #3
RE: N55 JB4 clicking
(08-06-2017 10:40 AM)akash Wrote:  Did you by any chance do any firmware updates on the JB

Nope, not the new board. Its using V5. 10

I updated my older board with the latest firmware and that's where the clicking started. After merging the grounds didn't work, BMS sold me a new board saying that was the issue - Now I'm in the same place after buying another boardSmashScreen

Flash tune FTW

'12 335i MSport "The Hulk"
'05 XRSi "The Black Pearl"
'97 323i "Silas"
'99 RXi

Previous:
'03 XRSi "Kit"
'95 180i SPORT "The AFE Authority"
'94 160i RS
'99 Polo playa
Find all posts by this user
Like Post Quote this message in a reply
08-06-2017, 12:29 PM (This post was last modified: 08-06-2017 12:30 PM by akash.)
Post: #4
RE: N55 JB4 clicking
Based on this "I updated my older board with the latest firmware and that's where the clicking started."

I would say first try to roll back to the firmware you had on before the issue started.

Yesterday i updated my firmware on my JB G5 and now for some reason the meth flow gauge hijack on the fuel comes on whenever it feels like but the Boost on oil temp works no issues. It did not happen with the firmware before the updated.

The supplier says its a power supply issue but only started to have this issue after the update. My JB worked perfect before

Im going to roll back to the firmware i had previously and see what happens.

AKASH
Masstronix E90 335i AT Sportpack (JB4, DP, DCI. Race flash 265wkw @622NM at KAR)
E90 323i Sportpack
Find all posts by this user
Like Post Quote this message in a reply
08-06-2017, 12:38 PM
Post: #5
RE: N55 JB4 clicking
Tiptoe Supplier wont admit to anything being their fault especially not in writing I agree with akash and roll back the update it seems as though thats where it all started...next thing you guys are having cars burning for no reason at all.

If that solves the problem I believe JB guys should refund for the new board you purchased, Im surprised they did not take the matter further and investigate the latest update. YesNo

This could be some great advertising for them....or maybe not. I for one wont be rushing out to buy a unit, especially with this weak support you guys are getting.

Z4 M Coupe, once U go Coupe you cant go back. Bluebiggrin
2012 125i Coupe
07 A4 Tdi - 125kw+++ added some extra Ponies via software + decat, EGR & DPF delete.
Find all posts by this user
Like Post Quote this message in a reply
08-06-2017, 01:41 PM
Post: #6
RE: N55 JB4 clicking
(08-06-2017 12:38 PM)MikeR Wrote:  Tiptoe Supplier wont admit to anything being their fault especially not in writing I agree with akash and roll back the update it seems as though thats where it all started...next thing you guys are having cars burning for no reason at all.

If that solves the problem I believe JB guys should refund for the new board you purchased, Im surprised they did not take the matter further and investigate the latest update. YesNo

This could be some great advertising for them....or maybe not. I for one wont be rushing out to buy a unit, especially with this weak support you guys are getting.

In retrospect I was silly not to revert to the old softwareHammerhead

But I followed the support from BMS thinking that they do this daily and the best resolution should come from them.

Unfortunately there is not much support in SA as the resellers are agents and also rely on BMS support. Post that you pay big money for small problems.

Regarding the software the first board had V5.11 that was upgraded to 5.14. The new board came with V5.10 so I expected this not to click is the version was older. None the less its worth trying theV5.11 again.

BMS support did come back to and proposed that I bridge the DME positive to the boost solenoid. Call me pessimistic, but I'm not to comfortable playing with the DME positive RedNo

'12 335i MSport "The Hulk"
'05 XRSi "The Black Pearl"
'97 323i "Silas"
'99 RXi

Previous:
'03 XRSi "Kit"
'95 180i SPORT "The AFE Authority"
'94 160i RS
'99 Polo playa
Find all posts by this user
Like Post Quote this message in a reply
08-06-2017, 05:29 PM
Post: #7
RE: N55 JB4 clicking
Update

Just rolled back the firmware and guess what no issues at all.

Gauges all work

AKASH
Masstronix E90 335i AT Sportpack (JB4, DP, DCI. Race flash 265wkw @622NM at KAR)
E90 323i Sportpack
Find all posts by this user
Like Post Quote this message in a reply
08-06-2017, 05:54 PM (This post was last modified: 08-06-2017 06:48 PM by FiRi@Rennzport.)
Post: #8
RE: N55 JB4 clicking
When ever you experience a problem just after an update, revert back to old firmware and test. Astounded that you were forced to buy a new board...actually shocking.

With regard to SA companies that sell jB4 not being able to support, I think you didn't do your homework there bud. RENNZPORT solves more then 90 percent of queries ourselves.

Hope you resolve the issue by reverting back to older firmware. If it works, I would personally not accept anything short of a refund.

Find all posts by this user
Like Post Quote this message in a reply
10-06-2017, 10:55 AM (This post was last modified: 10-06-2017 10:56 AM by //M SPORT.)
Post: #9
RE: N55 JB4 clicking
(08-06-2017 05:54 PM)FiRi@Rennzport Wrote:  With regard to SA companies that sell jB4 not being able to support, I think you didn't do your homework there bud. RENNZPORT solves more then 90 percent of queries ourselves.

Happy to accept that mate. Always thought Rennzport just sold the products. Where in JHB can I go to get it checked up, is there a Rennzport garage? Think I need a professional to check this out.

'12 335i MSport "The Hulk"
'05 XRSi "The Black Pearl"
'97 323i "Silas"
'99 RXi

Previous:
'03 XRSi "Kit"
'95 180i SPORT "The AFE Authority"
'94 160i RS
'99 Polo playa
Find all posts by this user
Like Post Quote this message in a reply
10-06-2017, 11:04 AM (This post was last modified: 10-06-2017 11:46 AM by FiRi@Rennzport.)
Post: #10
RE: N55 JB4 clicking
Pop us an email with the described problem, and we will initiate everything from there. Keep in mind we normally keep our FREE support limited to our clients who have purchased their units from us, however we willing to assist you seeing that you out of pocket and having a tough time.

Rennzport@live.co.za


Find all posts by this user
Like Post Quote this message in a reply
The following 2 users Like FiRi@Rennzport's post:
LevanM, YUBEN
10-06-2017, 12:53 PM
Post: #11
RE: N55 JB4 clicking
(10-06-2017 11:04 AM)FiRi@Rennzport Wrote:  Pop us an email with the described problem, and we will initiate everything from there. Keep in mind we normally keep our FREE support limited to our clients who have purchased their units from us, however we willing to assist you seeing that you out of pocket and having a tough time.

Rennzport@live.co.za

RENNZPORT FTWPraise

Current Rides
2006 E92 335i(206kw/474nm)
2006 Audi Sportsback 2.0T S-Tronic Ambition
Find all posts by this user
Like Post Quote this message in a reply
The following 1 user Likes YUBEN's post:
FiRi@Rennzport
10-06-2017, 01:23 PM
Post: #12
RE: N55 JB4 clicking
Thanks will do.

I see many old TTCC members here. Nice seeing some old members.

'12 335i MSport "The Hulk"
'05 XRSi "The Black Pearl"
'97 323i "Silas"
'99 RXi

Previous:
'03 XRSi "Kit"
'95 180i SPORT "The AFE Authority"
'94 160i RS
'99 Polo playa
Find all posts by this user
Like Post Quote this message in a reply
19-06-2017, 11:59 AM
Post: #13
RE: N55 JB4 clicking
Hi chaps,

An update...

It seems I finally resolved the clicking issue!

I decide to leave the JB in and try playing with the harness incase there were any connection issues. I ended up butchering the harness eliminating the plug connecting the RHD extension, but the clicking still remained. I then shortened the cable suspecting a certain patch may have had the short - and yet again click click..

My last hope was to try and change the Tmap plug. With the purple patch not used on the N55, I was able to 'borrow' the plug from there and wire it the same as the original Tmap. IT WORKED!Cartel The clicking has finally stopped.

There is a single click now and then but I assume that's normal as there is no continuous clicking.

Just 2 things I need some advise on:
1. I got a 2c90 code and limp mode in map0. I know 2c90 is a tuner code, but should it throw the car in limp mode?
2. I am currently running map 5 and the car feels quite sluggish at the lower end of the rev. It seems to be getting better as it learns but I only have had 2 trips since (no error codes). Is this normal?

'12 335i MSport "The Hulk"
'05 XRSi "The Black Pearl"
'97 323i "Silas"
'99 RXi

Previous:
'03 XRSi "Kit"
'95 180i SPORT "The AFE Authority"
'94 160i RS
'99 Polo playa
Find all posts by this user
Like Post Quote this message in a reply
07-07-2017, 11:41 AM
Post: #14
RE: N55 JB4 clicking
(10-06-2017 01:23 PM)//M SPORT Wrote:  Thanks will do.

I see many old TTCC members here. Nice seeing some old members.

looks like all the old ttcc members bought 135i's
im from there as well "thoonsil"

Current-2013 N55 135i DCT Mperformace Exhaust,DP,JB4
x-2005 S2000
x-2012 GTI
x-1996 Civic Vtec
x-1999 RXi
x-1990GLi 20v
x-1988 Twincam
Find all posts by this user
Like Post Quote this message in a reply
The following 1 user Likes jovbrat's post:
r0ckf1re
11-07-2017, 09:42 AM
Post: #15
RE: N55 JB4 clicking
Jovy - nice to see you bud.

After the toys, I skipped the 2.0l turbos and went straight to the X35s..

Problem is these are nowhere as reliable as my old machines.

'12 335i MSport "The Hulk"
'05 XRSi "The Black Pearl"
'97 323i "Silas"
'99 RXi

Previous:
'03 XRSi "Kit"
'95 180i SPORT "The AFE Authority"
'94 160i RS
'99 Polo playa
Find all posts by this user
Like Post Quote this message in a reply
Post Reply 




User(s) browsing this thread:
1 Guest(s)

Return to TopReturn to Content